sharp安装报错问题解决方案

11-13
评论
字数统计:461(字)
最近经常出现sharp报错问题,目前我接触的两种情况已经有了解决方案,可能案例不同解决方案也不同,如有补充请留言。

Case 1 : npm安全问题导致安装失败

这里是因为npm为了安全不允许root用户运行,没有拿到该有的权限,导致node-gyp在写文件时蹦了。这位兄台解释的挺清楚,可以看看(https://segmentfault.com/q/1010000019365121)。 这类情况一般运行 npm install --unsafe-perm 即可解决。


Case 2 :缺少其他依赖库

系统缺少c++相关的底层依赖

brew install gcc
brew reinstall vips
brew info vips
yarn 

Case 3 ... 待添加


本文链接:https://blog.crazylei.com/art/0be3e741
版权声明: 本博客所有文章除特别声明外,均采用CC BY 4.0 CN协议 许可协议。转载请注明出处!

评论

正在加载评论...

©2022 Crazylei Bolg沪ICP备20001821号